• Advertisement

Electrical issue 4jg2

Discuss all things related to 4x4, Isuzu's and anything else related to getting out and about

Electrical issue 4jg2

Postby nzshooter » Sun Jan 18, 2015 7:37 am

Hey guys my 1994 Isuzu mu, 4jg2 is having some problems. The 3 lights on the dash came on along with the fan/aircon not working which I understand is the relay, due to the alternator overcharging. Truck has been running fine, I have been keeping an eye on the volt meter which only just reaches 16v at high rpm. My intentions were new alternator and relay very soon.

However, lastnite the truck died (very strange) then upon trying to start the glow light would not come on and no click under the bonnet and it just turns over.
I found that the fuse called: 8 engine back. L which is a 15A was blown and continues to blow new fuse when attempting to start. So my guess there is a main relay before this that is shot? Or maby the glow plugs are shot?
Any info greatly appreciated
Cheers
nzshooter
Isuzu Baby
 
Posts: 7
Joined: Sun Jul 13, 2014 7:04 am
Age: 24
Country: new zealand
City: chch
Vehicle: 1994 Isuzu mu 3.1 manual

Re: Electrical issue 4jg2

Postby turnturn » Sun Jan 18, 2015 2:42 pm

I think that this fuse also controls the fuel shut off solenoid (75% sure).

I recently bought a Mu (not going) for spare parts that this fuse had blown. Turned out that during a recent clutch repair the wiring loom running over the back of the motor (fuel shut off, rev counter etc) had been pinched between the bell housing and the engine.

When I was playing around trying to get it going it gave similar symtoms to your description above (second paragraph). I ended up hot wiring it (wire/fuse/switch to fuel cut off solenoid).

Has any other work been done to your vehicle lately? The problem that I have described above took a couple of weeks to happen for the previous owner.
User avatar
turnturn
Global Moderator
 
Posts: 916
Joined: Wed May 13, 2009 4:26 pm
Age: 55
Country: New Zealand
City: Dunedin
Vehicle: 1992 Isuzu Mu 2.8 Manual (UCS55)
Snorkle, Intercooled
1993 Isuzu Mu 2.8 Manual (UCS55)
Spare Parts/Donor
1994 Isuzu Mu 3.1 Manual (UCS69)
Snorkle, Intercooled
1996 Isuzu Mu 3.1 Manual (UCS69)
Completely Standard

Re: Electrical issue 4jg2

Postby nzshooter » Mon Jan 19, 2015 11:11 am

Cheers for the reply. No other work has been done recently other than wheel bearings etc, nothing to effect that wire? Hmm it's very strange. I will see if there is any damage to that wire
nzshooter
Isuzu Baby
 
Posts: 7
Joined: Sun Jul 13, 2014 7:04 am
Age: 24
Country: new zealand
City: chch
Vehicle: 1994 Isuzu mu 3.1 manual

Re: Electrical issue 4jg2

Postby orion » Mon Feb 23, 2015 4:46 pm

Hi there, I had a similar question...

I had the glow plug timer not working well, and the mechanic disconnected the temperature sensor. It was hard to start when hot because the glow plugs wouldn't stay on long enough.

When i got the car back it would overcharge the battery and get past 16V on the dash gauge past 2.5k revs. The auto transmission also wouldn't go into 4th. The transmission problem they related back to the temp sensor on the glow timer.
I also ended up having to fork out for a new alternator.

would having the temp sensor fail or removed cause the over-voltage and stuff up the alternator? does anyone have a circuit diagram or can point me in the right direction?
orion
I'm only here for the information
 
Posts: 1
Joined: Mon Feb 23, 2015 4:36 pm
Age: 27
Country: NZ
City: Dunedin
Vehicle: 1996 Isuzu Mu

Re: Electrical issue 4jg2

Postby geeves » Tue Feb 24, 2015 1:53 pm

4th gear quite possibly but alternator no. When a 4jg2 is warm it doesnt need glow plugs.
Sanding your knuckles before starting work can help. That way you cant skin them
User avatar
geeves
Site Admin
 
Posts: 8417
Joined: Sun May 10, 2009 1:36 pm
Location: wellington
Age: 55
Country: NZ
City: Wellington
Vehicle: 94 bighorn 4jg2
2004 Honda CRV


Return to General Isuzu and 4x4 discussion

Who is online

Users browsing this forum: No registered users and 2 guests