• Advertisement

new injectors and front seal injetor pump

Get help fixing your Isuzu from other club members

new injectors and front seal injetor pump

Postby stardog » Mon Sep 25, 2017 7:02 pm

I finally got around to installing new injectors and the leaking front seal on the injector pump.
The thing is no 3 on inlet port on manifold was full of oily black gunk 1-2 and 4 was clean when reinstalling the pump there is a 0 and a V mark on the pump gear to get the 0 mark to line up on TDC mark I had to remove inlet manifold this a rodeo 4jb1t engine not belt drive I got TDC while injectors where out and marked harmonic balancer it has spun then marked the 12 degrees with some white out for the static timing 0.5 on the dial gauge.
But I don't think I got all of the air out of fuel system it runs good at idle but is gutless should I crack the pipe at no 1 injector to bleed the system again I only bled it at the fuel filter it ran rough and had a miss before I done all of this so the timing was out I think.
stardog
Isuzu Deity
 
Posts: 840
Joined: Tue Nov 10, 2009 6:14 pm
Location: sydney nsw australia
Age: 57
Country: australia
City: sydney
Vehicle: 94 mu was 3.1 turbo intercooled now 2.8td rodeo gear drive engine and intercooled and fuel delivery turned up 3" system from turbo 5 speed manual arb bullbar 13000 LB winch max winch snorkel HID headlights HID IPF spotlights blue led dash lights LOKKA front diff new bushes shocks all round 80 ch unden uhf sony xplode mp3 player back seats removed and storge system put in.
96 wizard 3.1 pretty stock for now but have plans intercooler bulbar winch snorkel.

Return to Engine

Who is online

Users browsing this forum: No registered users and 2 guests