• Advertisement

4jg2 93 no fuel out the back of the injector pump

Get help fixing your Isuzu from other club members

4jg2 93 no fuel out the back of the injector pump

Postby Swatty » Wed Oct 18, 2017 4:22 pm

Hey guys, did a head gasket on the 4jg2 however i can't seem to get it started again. I've checked fuel and I have fuel coming into the injector pump however nothing is coming out the far end. It primes to hard however this is all on the tank side of the pump.

I'm running out of ideas and after spending a lot of money trying to get this girl back on the road I'm struggling for ideas.

Any help out there??
Swatty
Isuzu Baby
 
Posts: 5
Joined: Sun Jul 09, 2017 6:18 pm
Age: 27
Country: NZ
City: Hamilton
Vehicle: Iszuz Bighorn 3.1D 4JG2

Re: 4jg2 93 no fuel out the back of the injector pump

Postby stardog » Fri Oct 20, 2017 5:39 pm

Have you got power to the fuel cut off solenoid and all the wires connected up properly to the pump.
stardog
Isuzu Deity
 
Posts: 840
Joined: Tue Nov 10, 2009 6:14 pm
Location: sydney nsw australia
Age: 57
Country: australia
City: sydney
Vehicle: 94 mu was 3.1 turbo intercooled now 2.8td rodeo gear drive engine and intercooled and fuel delivery turned up 3" system from turbo 5 speed manual arb bullbar 13000 LB winch max winch snorkel HID headlights HID IPF spotlights blue led dash lights LOKKA front diff new bushes shocks all round 80 ch unden uhf sony xplode mp3 player back seats removed and storge system put in.
96 wizard 3.1 pretty stock for now but have plans intercooler bulbar winch snorkel.

Re: 4jg2 93 no fuel out the back of the injector pump

Postby Swatty » Sat Oct 21, 2017 9:55 am

I didn't touch any wiring around the injector pump and it seems to be pushed firmly on. I hatend the electrical side of cars and I have no idea what the 6 different points of wiring going into the pump are for
Swatty
Isuzu Baby
 
Posts: 5
Joined: Sun Jul 09, 2017 6:18 pm
Age: 27
Country: NZ
City: Hamilton
Vehicle: Iszuz Bighorn 3.1D 4JG2

Re: 4jg2 93 no fuel out the back of the injector pump

Postby stardog » Sat Oct 21, 2017 10:05 am

Old mate in nth Qld had a crook stop solenoid that wouldn't let the truck start run a wire from positive on battery to the stop solenoid on the pump and see if it clicks.
If it clicks turn the key and see if it starts im assuming your pump is a mechanical one.
stardog
Isuzu Deity
 
Posts: 840
Joined: Tue Nov 10, 2009 6:14 pm
Location: sydney nsw australia
Age: 57
Country: australia
City: sydney
Vehicle: 94 mu was 3.1 turbo intercooled now 2.8td rodeo gear drive engine and intercooled and fuel delivery turned up 3" system from turbo 5 speed manual arb bullbar 13000 LB winch max winch snorkel HID headlights HID IPF spotlights blue led dash lights LOKKA front diff new bushes shocks all round 80 ch unden uhf sony xplode mp3 player back seats removed and storge system put in.
96 wizard 3.1 pretty stock for now but have plans intercooler bulbar winch snorkel.


Return to Engine

Who is online

Users browsing this forum: No registered users and 2 guests