• Advertisement

Check engine light and no throttle repsonse!

Get help fixing your Isuzu from other club members

Check engine light and no throttle repsonse!

Postby Ljbrodeo » Sun Jan 27, 2019 9:58 am

My 05 rodeo 4jh1, is illuminating the check engine light and the revs are stuck at 1100rpm and will not respond to any throttle commands until turning off engine and starting again then same thing happens 50m up the road, I ha w cleaned egr, cleaned maf sensor replaced fuel filters, I replaced the throttle position sensor and still have no luck, I have used a scan tool and there is no codes stored for the fault, has anyone had a similar problem or even fixed a problem because it is doing my head in and only going to get more expensive as the mechanic cannot figure it out!
Ljbrodeo
I'm only here for the information
 
Posts: 2
Joined: Sun Jan 27, 2019 9:52 am
Age: 26
Country: Australia
City: Hervey Bay
Vehicle: 2005 holden ra rodeo 3L TD 4JH1

Re: Check engine light and no throttle repsonse!

Postby DonaldNZ » Sat Feb 16, 2019 5:37 pm

try a different mechanic quickly, do not spend anymore money with your current mechanic.
DonaldNZ
Isuzu Junior
 
Posts: 86
Joined: Sun Dec 30, 2018 9:42 pm
Age: 53
Country: NZ
City: CHCH
Vehicle: stock wizard 4jg2t efi & 30-43le external pressure control via throttle quadrant

Re: Check engine light and no throttle repsonse!

Postby Myarmila24311 » Thu May 02, 2019 5:24 pm

My 20 cent looks like the ecu top on the pump have faulty. VP44 common problem
Myarmila24311
Isuzu Baby
 
Posts: 16
Joined: Thu May 02, 2019 1:05 pm
Age: 40
Country: Malaysia
City: SANDAKAN
Vehicle: Isuzu Trooper 4JG2


Return to Engine

Who is online

Users browsing this forum: Google [Bot] and 6 guests