• Advertisement

Mu wont turn over after turn off ??sensor??

Get help fixing your Isuzu from other club members

Mu wont turn over after turn off ??sensor??

Postby MUDAWG » Thu Apr 12, 2018 5:16 pm

Hi all
I have a 1997 mu 3.1 with a very anoying problem
When i turn the truck off after runing it. It wont turn back on for a while just keep trying untill it goes or i come back in an hour. I thought this might be starter but have just replaced that and battery (alternator is sweet) but it is still continuing could this be a sensor for wheel lock or auto trans thats starting to go. Has anyone had this problem bifore.
Cheers Brad
MUDAWG
I'm only here for the information
 
Posts: 2
Joined: Thu Jan 04, 2018 11:04 am
Age: 19
Country: New Zealand
City: Auckland
Vehicle: 1997 mu ltd 3.1t

Re: Mu wont turn over after turn off ??sensor??

Postby geeves » Thu Apr 12, 2018 5:29 pm

Is it automatic? Is the gear selector showing park or neutral when trying to start? If its auto and not showing this the inhibitor switch is going. You could try wrigging the selector side to side while starting but long term you need to replace the inhibitor switch
Sanding your knuckles before starting work can help. That way you cant skin them
User avatar
geeves
Site Admin
 
Posts: 8210
Joined: Sun May 10, 2009 1:36 pm
Location: wellington
Age: 55
Country: NZ
City: Wellington
Vehicle: 94 bighorn
96 wizard

Re: Mu wont turn over after turn off ??sensor??

Postby MUDAWG » Fri Apr 13, 2018 6:10 pm

Yeah its auto showing park ill have a look at that and get back. You legend
MUDAWG
I'm only here for the information
 
Posts: 2
Joined: Thu Jan 04, 2018 11:04 am
Age: 19
Country: New Zealand
City: Auckland
Vehicle: 1997 mu ltd 3.1t


Return to Electrical

Who is online

Users browsing this forum: No registered users and 1 guest