• Advertisement

Odometer stopped. Check trans light on. Gearbox playing up

Get help fixing your Isuzu from other club members

Odometer stopped. Check trans light on. Gearbox playing up

Postby Itstime » Thu May 21, 2020 9:56 am

Hi there,

On my Bighorn (96 XS Plaisir 4JG2 engine) the odometer played up and stopped working. Check trans light on. Gearbox doesn't shift into 4th gear.

I noticed two weeks ago the odometer would some days not work in the morning for the first 200 meters or so, then went fine. Did it again some days later. Then it went funny and the gearbox didn't know what to do. Now odometer stopped working, check trans light on and gearbox doesn't go into 4th.

What is the most common cause for this? Speed sensor? Wiring? Corroded plug on speed sensor? Truck was often in salt water with prev owner.

My garage had a look. No clue. Wants to ask an auto electrician. But I am doubting they know where to start searching.

Any ideas?

Thanks!
Itstime
Isuzu Baby
 
Posts: 6
Joined: Mon Dec 24, 2018 8:48 am
Age: 44
Country: New Zealand
City: Tauranga
Vehicle: Bighorn 96

Re: Odometer stopped. Check trans light on. Gearbox playing

Postby geeves » Thu May 21, 2020 5:28 pm

Sounds like speed sensor although that also affects the speedo. My wizard did that. Would be fine at first but then speedo would be all over the place then settle at 0. Auto sparky tested the sensor and it worked perfectly for a few minutes then went haywire. New sensor fixed it
Sanding your knuckles before starting work can help. That way you cant skin them
User avatar
geeves
Site Admin
 
Posts: 8501
Joined: Sun May 10, 2009 1:36 pm
Location: wellington
Age: 55
Country: NZ
City: Wellington
Vehicle: 94 bighorn 4jg2
2004 Honda CRV

Re: Odometer stopped. Check trans light on. Gearbox playing

Postby Itstime » Sun May 24, 2020 3:07 pm

Hi Geeves,

Found it. It was just a rotten wire near the plug that goes into the speed sensor. Thanks for your advice.
Itstime
Isuzu Baby
 
Posts: 6
Joined: Mon Dec 24, 2018 8:48 am
Age: 44
Country: New Zealand
City: Tauranga
Vehicle: Bighorn 96


Return to Electrical

Who is online

Users browsing this forum: No registered users and 1 guest

cron