• Advertisement

1992 4JB1T Charging Issue

Get help fixing your Isuzu from other club members

1992 4JB1T Charging Issue

Postby IsuzuCamper » Tue Jan 08, 2019 12:17 pm

1992 Isuzu Rodeo Camper Turbo Diesel. I'm getting only 12.25 at the most when at idle at the battery. Changed the grounds and and other cables possible. Tested the Charging relay (BLue) tested good but ordered another. I pulled the alternator to get tested tomorrow from a shop that is familiar with that type if Isuzu Alternator with the vacuum pump. Any thing else I should be looking at? Been working on 7.3's and Cumins for years, This is a new one. Happy to learn.

Cheers Mates,

Patrick

Boulder Colorado
IsuzuCamper
Isuzu Baby
 
Posts: 12
Joined: Tue Jan 08, 2019 12:02 pm
Location: Boulder, Colorado
Age: 46
Country: United States
City: Boulder
Vehicle: 1992 Isuzu Rodeo Camper

Re: 1992 4JB1T Charging Issue

Postby geeves » Tue Jan 08, 2019 1:47 pm

Unless the battery is completly charged that reading at idle isnt wrong. Test it at at least 1500 rpm. Below that the losses in the battery prevent it showing full voltage. Otherwise the regulator, diode pack or stator coils might be faulty.
I trust you have verified your multimeter is correct?
Sanding your knuckles before starting work can help. That way you cant skin them
User avatar
geeves
Site Admin
 
Posts: 8358
Joined: Sun May 10, 2009 1:36 pm
Location: wellington
Age: 55
Country: NZ
City: Wellington
Vehicle: 94 bighorn
96 wizard

Re: 1992 4JB1T Charging Issue

Postby IsuzuCamper » Tue Jan 08, 2019 2:36 pm

Thanks Geeves for the quick reply. Yes. I tested 2 other vehicles with the multi-meter. Both were charging correctly and multi-meter was working. I tried to drive it at night and the light dies and was losing power. Something isn't right. Hopefully the alternator test gives me a start tomorrow. I'll be posting back right away. Otherwise, it drives so good. Runs smooth. No smoke. Very happy once I get this fixed.

Cheers

Patrick
IsuzuCamper
Isuzu Baby
 
Posts: 12
Joined: Tue Jan 08, 2019 12:02 pm
Location: Boulder, Colorado
Age: 46
Country: United States
City: Boulder
Vehicle: 1992 Isuzu Rodeo Camper

Re: 1992 4JB1T Charging Issue UPDATE

Postby IsuzuCamper » Thu Jan 10, 2019 10:04 am

Pulled the alternator this morning and got it tested. Alternator is good. All connections coming out of the alternator test good. So moving on up the ladder. Next the connection and wire feeding the main power distributor. Any thing else I should check?

Cheers,

Patrick
IsuzuCamper
Isuzu Baby
 
Posts: 12
Joined: Tue Jan 08, 2019 12:02 pm
Location: Boulder, Colorado
Age: 46
Country: United States
City: Boulder
Vehicle: 1992 Isuzu Rodeo Camper

Re: 1992 4JB1T Charging Issue UPDATE 2

Postby IsuzuCamper » Thu Jan 10, 2019 10:50 am

After some more internet research, I found some information on the connection from the ignition to the alternator. "idiot light" I've heard of it but never had to diagnose it. I'll post back if this is it. I hope so.
IsuzuCamper
Isuzu Baby
 
Posts: 12
Joined: Tue Jan 08, 2019 12:02 pm
Location: Boulder, Colorado
Age: 46
Country: United States
City: Boulder
Vehicle: 1992 Isuzu Rodeo Camper


Return to Electrical

Who is online

Users browsing this forum: No registered users and 2 guests

cron