• Advertisement

No oil pressure for engine lubrication

Get help fixing your Isuzu from other club members

No oil pressure for engine lubrication

Postby wonderd » Sat Sep 04, 2021 4:01 am

Hi there

i have seen very old posts about this, maybe now there is more knoledge?

When i start the car after a coouple of day of it sitting, the oil lamp stays on for more then 30 seconds (and no oil comes up to the turbo, so it's not the oil unit).
Cleaned the strainers in the sump, cleaned the oil cooler assembly, changed oil and filter, now it's worse - the light stays on for ever.

I was reading there is a main oil relief valve? how do i get to it? maybe it's stuck open?

thank you for an help.
Elad.
wonderd
I'm only here for the information
 
Posts: 1
Joined: Wed Mar 11, 2015 3:35 am
Age: 39
Country: Israel
City: Rosh Pina
Vehicle: 2002 3.0L trooper with TOD

Re: No oil pressure for engine lubrication

Postby geeves » Sat Sep 04, 2021 6:38 am

What oil did you use?
Sanding your knuckles before starting work can help. That way you cant skin them
User avatar
geeves
Site Admin
 
Posts: 8703
Joined: Sun May 10, 2009 1:36 pm
Location: wellington
Age: 60
Country: NZ
City: Rangiora
Vehicle: 94 bighorn 4jg2
2004 Honda CRV

Re: No oil pressure for engine lubrication

Postby andy120 » Sat Sep 11, 2021 4:15 pm

there is a pressure relief under the oil filter. i forget if its the front or rear of the 2 bolts there. i had a motor that wouldnt pressurise. even with the relief peened closed it still wouldnt. got another motor after 6 months trying to work it out.
andy120
Isuzu Junior
 
Posts: 126
Joined: Tue Jun 02, 2015 6:38 am
Location: Upside down in a ditch
Age: 40
Country: NZ
City: Gore
Vehicle: 2 manual Wizards + 1 auto

Re: No oil pressure for engine lubrication

Postby Brinky » Wed Sep 15, 2021 9:19 am

Definately worth checking the oil relief valve. I had a car once that the oil light didn't go out. Found a piece of aluminium wedged in it that looked like it came from a piston skirt. Put it back together and ran fine. I guess the pick up strainer had fallen out or didn't have one. Might pay to attach a manual oil pressure gauge and see what that says.
User avatar
Brinky
Isuzu Baby
 
Posts: 34
Joined: Thu Dec 06, 2018 6:45 pm
Age: 56
Country: New Zealand
City: AUCKLAND
Vehicle: 1992 Isuzu Mu 2.8l UCS55
Auto Trans, Inter-cooled, 2" Raised, Standard dump pipe with 2.5" exhaust, K&N filter, Snorkel, Raised Trans and Transfer Box with modified cross brace, Not lifted, 32 muds, Runva 9500 winch, disconnected sway bar, double air lockers

Re: No oil pressure for engine lubrication

Postby geeves » Wed Sep 15, 2021 1:55 pm

Another possibility is an air leak where the strainer attaches to the block
Sanding your knuckles before starting work can help. That way you cant skin them
User avatar
geeves
Site Admin
 
Posts: 8703
Joined: Sun May 10, 2009 1:36 pm
Location: wellington
Age: 60
Country: NZ
City: Rangiora
Vehicle: 94 bighorn 4jg2
2004 Honda CRV


Return to Engine

Who is online

Users browsing this forum: Google [Bot] and 9 guests